您尚未登录。

#1 2023-02-25 12:31:56

Franklin Yu
会员
注册时间: 2023-02-24
帖子: 10

[搁置] Git 包的版本号是否可以和稳定包的不一致?

Y 问题是,我希望稳定包 foobar 的版本是 1.2.3 的格式,但 Git 版是 r321.deadbeef 的格式,AUR 社区是否会有意见?

X 问题

打包必要性:iTerm2 是 macOS 上的终端,其自带一些脚本,让 shell 和 iTerm2 交互。这些脚本一般随 iTerm2 分发,但也可以在 Linux 上运行。典型的场景是 macOS SSH 至 Linux 服务器上运行 imgcat。

其他背景信息:iTerm2 代码库叫 iTerm2,是正规的版本格式,形如 3.1.15。我维护 iterm2-shell-integration 这个 AUR 包,版本号采用的是 iTerm2 主体的版本号。所有脚本都在 Git 仓库 iTerm2-shell-integration 下,这个仓库又是 iTerm2 的一个 Git 子模块。详情可阅读 PKGBUILD。

问题:我初步打算另外开一个对应的 Git 包。如果我仍用 iTerm2 仓库作为 source,则无法吸收 iTerm2-shell-integration 的最新更新,因为是 Git 子模块;如果我改 iTerm2-shell-integration 仓库作为 source,那我就需要在 PKGBUILD 中单独维护版本号,因为这个仓库根本没 tag。我想要尝试的做法是稳定包使用 3.1.15 这样的正规版本号,而 Git 包直接用 r321.deadbeef 这样的版本号,从而无需单独维护版本号。想听听大家的看法。

最近编辑记录 Franklin Yu (2023-02-28 07:55:17)

离线

#2 2023-02-25 12:34:41

Franklin Yu
会员
注册时间: 2023-02-24
帖子: 10

Re: [搁置] Git 包的版本号是否可以和稳定包的不一致?

元问题:本版块和隔壁版块有啥不同?感觉许多 AUR 的包都是打包问题,且又提到了 PKGBUILD……

离线

#3 2023-02-25 13:42:41

依云
会员
所在地: a.k.a. 百合仙子
注册时间: 2011-08-21
帖子: 8,309
个人网站

Re: [搁置] Git 包的版本号是否可以和稳定包的不一致?

你可以去子模块里挖版本号呀。

离线

#4 2023-02-25 13:45:00

Franklin Yu
会员
注册时间: 2023-02-24
帖子: 10

Re: [搁置] Git 包的版本号是否可以和稳定包的不一致?

依云 说:

你可以去子模块里挖版本号呀。

你说的是哪种情况?是用 iTerm2 做源的情况,还是直接用 iTerm2-shell-integration 做源的情况?

离线

#5 2023-02-25 13:51:54

依云
会员
所在地: a.k.a. 百合仙子
注册时间: 2011-08-21
帖子: 8,309
个人网站

Re: [搁置] Git 包的版本号是否可以和稳定包的不一致?

用 iTerm2-shell-integration 呀。哦,这个是没有对应的 iTerm2 的?那就用日期作版本号吧。用提交数做版本号太难读了。

离线

页脚