您尚未登录。

#1 2024-02-11 14:21:05

InfinityWolf
会员
注册时间: 2024-02-11
帖子: 3

[已解决] yay等AUR助手在安装软件时git提示该文件夹不是该仓库的克隆

如题

[infinitywolf@org aur-talk-git]$ yay aur-talk-git
1 aur/aur-talk-git r11.ad39887-1 (+8 0.00) 
    A script to fetch and display AUR package comments
==> 要安装的包 (示例: 1 2 3, 1-3 或 ^4)
==> 1
AUR Explicit (1): aur-talk-git-r11.ad39887-1
:: PKGBUILD 是最新的,跳过下载: aur-talk-git
  1 aur-talk-git                             (构建文件已存在)
==> 清理哪些软件包的构建文件?
==> [N]没有 [A]全部 [Ab]中止 [I]已安装 [No]未安装 或 (1 2 3, 1-3, ^4)
==> A
:: 正在删除 (1/1): /home/infinitywolf/.cache/yay/aur-talk-git
HEAD 现在位于 15de277 depend on python explicitely; use https
正删除 src/
  1 aur-talk-git                             (构建文件已存在)
==> 显示哪些包的差异?
==> [N]没有 [A]全部 [Ab]中止 [I]已安装 [No]未安装 或 (1 2 3, 1-3, ^4)
==> A
 -> aur-talk-git: 没有更改 -- 跳过

:: 继续安装? [Y/n] y
==> 正在创建软件包:aur-talk-git r11.ad39887-1 (2024年02月11日 星期日 14时18分29秒)
==> 获取源代码...
==> 错误: /home/infinitywolf/.cache/yay/aur-talk-git/aur-talk 不是 https://github.com/GermainZ/aur-talk 的克隆
    正在放弃...
 -> 下载源文件时出错: /home/infinitywolf/.cache/yay/aur-talk-git 
	 context: exit status 1 
	 

:: (1/1) 正在解析 SRCINFO: aur-talk-git
==> 正在创建软件包:aur-talk-git r11.ad39887-1 (2024年02月11日 星期日 14时18分29秒)
==> 正在检查运行时依赖关系...
==> 正在检查编译时依赖关系
==> 获取源代码...
==> 错误: /home/infinitywolf/.cache/yay/aur-talk-git/aur-talk 不是 https://github.com/GermainZ/aur-talk 的克隆
    正在放弃...
 -> 生成时出错: aur-talk-git-exit status 1
 -> 无法安装以下软件包, 需要手动介入处理:
aur-talk-git - exit status 1

最近编辑记录 InfinityWolf (2024-02-12 14:07:51)

离线

#2 2024-02-11 17:29:27

依云
会员
所在地: a.k.a. 百合仙子
注册时间: 2011-08-21
帖子: 8,305
个人网站

Re: [已解决] yay等AUR助手在安装软件时git提示该文件夹不是该仓库的克隆

可能是换 url 了。到那个目录下 git remote -v 看看,不一样的话就 git remote set-url 更新一下。

离线

#3 2024-02-12 14:07:34

InfinityWolf
会员
注册时间: 2024-02-11
帖子: 3

Re: [已解决] yay等AUR助手在安装软件时git提示该文件夹不是该仓库的克隆

依云 说:

可能是换 url 了。到那个目录下 git remote -v 看看,不一样的话就 git remote set-url 更新一下。

有用,感谢。

离线

页脚