您尚未登录。

#1 2024-05-20 07:24:49

bookman
会员
注册时间: 2022-04-21
帖子: 15

升级系统安装icu出现破坏依赖的问题

今早升级系统显示 错误:无法准备事务处理 (无法满足依赖关系) 问题 无法解决,待请教解决方法。

https://bin.disroot.org/?782dbe5b2f9643 … tpfBhuHzLt

离线

#2 2024-05-20 08:30:48

依云
会员
所在地: a.k.a. 百合仙子
注册时间: 2011-08-21
帖子: 8,698
个人网站

Re: 升级系统安装icu出现破坏依赖的问题

你真的需要 qt5-webkit 吗?

离线

#3 2024-05-20 10:28:30

Duter2016
会员
注册时间: 2023-07-25
帖子: 11

Re: 升级系统安装icu出现破坏依赖的问题

遇到同样问题,检查下,qt5-webkit是作为goldendict-git的依赖安装上的

离线

#4 2024-05-20 10:35:40

依云
会员
所在地: a.k.a. 百合仙子
注册时间: 2011-08-21
帖子: 8,698
个人网站

Re: 升级系统安装icu出现破坏依赖的问题

需要的话那得自己想办法 rebuild qt5-webkit 啦。archlinuxcn 仓库的 qt5-webkit 打包失败了,得找维护者修。

离线

#5 2024-05-20 13:04:28

teaper
会员
注册时间: 2020-11-17
帖子: 5
个人网站

Re: 升级系统安装icu出现破坏依赖的问题

Duter2016 说:

遇到同样问题,检查下,qt5-webkit是作为goldendict-git的依赖安装上的

先使用 pactree -r qt5-webkit 看看是不是只有 goldendict-git 依赖它 
如果是,那就将 goldendict-git 和 qt5-webkit 卸载了 
直接 yay -S goldendict-ng 
goldendict-git 上次更新还是 2022-06-08 ,换成 goldendict-ng 好一点,依赖 qt6-webkit

最近编辑记录 teaper (2024-05-20 13:07:53)


为学日益,为道日损!

离线

#6 2024-05-20 13:45:08

Duter2016
会员
注册时间: 2023-07-25
帖子: 11

Re: 升级系统安装icu出现破坏依赖的问题

teaper 说:
Duter2016 说:

遇到同样问题,检查下,qt5-webkit是作为goldendict-git的依赖安装上的

先使用 pactree -r qt5-webkit 看看是不是只有 goldendict-git 依赖它 
如果是,那就将 goldendict-git 和 qt5-webkit 卸载了 
直接 yay -S goldendict-ng 
goldendict-git 上次更新还是 2022-06-08 ,换成 goldendict-ng 好一点,依赖 qt6-webkit

谢谢,没有其他软件依赖 qt5-webkit。已经卸载goldendict-git,刚换goldendict-ng和pot-translation.

不过自己手太快了,卸载完,就系统整体升级了,升级后出现其他AUR中装的软件启动不起来了,比如ungoogled-chromium。影响不大,应该一两天都能升级跟上来……

离线

#7 2024-05-20 16:14:19

bookman
会员
注册时间: 2022-04-21
帖子: 15

Re: 升级系统安装icu出现破坏依赖的问题

谢谢各位的提示,问题解决了!

离线

页脚